nix/modules/wm/foot/default.nix
2024-11-27 11:26:28 +01:00

25 lines
405 B
Nix

{
lib,
config,
username,
...
}: {
options = {
foot.enable = lib.mkEnableOption "";
};
config = lib.mkIf config.foot.enable {
home-manager.users.${username} = {
programs.foot = {
enable = true;
settings = {
main = {
pad = "2x2";
font = lib.mkForce "RobotoMono Nerd Font:size=12";
};
};
};
};
};
}